遊戯王のコレめせ!

コレクターの目線から遊戯王を分析するブログ。最新情報・相場情報・コレクターのための情報など幅広くまとめます。

 MENU

【2018年2月】はてなpro移行後、独自ドメイン設定で躓いたことをまとめてみた



単刀直入に言います、独自ドメイン取得から反映まで「5日」かかりました。正直ここまでかかるとは思いませんでしたね…

さすがに私みたいにまごついた人はそういないと思いますが、いつまで経っても見れないじゃないか!と同じ状況にある人に向けてまとめてみます。

 

 

はじめに

 

まず「はてな 独自ドメイン」と検索すると、関連記事はいくらでも出てきます。

こちらの記事は記事作成時点に置いて一番アッサリまとまっていると思います。検索上位にもでていますね。

 

www.mutant-tetsu.com

 

こちらの内容に沿うと一見すぐ終わることのように見えます。

大体の人はこういった記事で問題なく設定できるでしょう。

 

ただ、私の場合は違いました。

ネットワークの知識は殆どありませんでしたが、PCには強かったので「まあなんとかなるだろう」と思っていたところ、いつまで経っても接続できませんでした。

ネットワークに強い人はそういないと思いますので、こういったまとめ記事に無いような現象が1つ起こっただけで「何か間違った?!」と不安になりますよね。

おまけに調べてみると分かるのですが「似たような記事ばかりで、解決策がわかりやすく明示されている記事が明らかに少ない」のです。

そのため私が躓いた点をまとめていきます。

 

 

 

躓いた点1「このドメインは、お名前.comで取得されています。」

 

f:id:aqn1313:20180206134948p:plain

 

独自ドメインの取得後、いざ検索した際に表示された画面です。

調べてみると考えられる可能性は2つ

  1. 設定反映に時間がかかっているため
  2. 設定になにか間違いがある

設定反映には早い人で1時間足らずで、長い人で48時間とあったので実際に48時間待って見ました。結果は変化なし。設定に間違いがあると思ったのですが、見直しても間違いはありませんでした。

そして深く調べているとミスリード記事も見つかります。それが「ネームサーバーの変更」に関する記事です。「このドメインは~」が表示された際の主な理由として、新しくサイトを作成した際にサイトを保管しているサーバーにアクセスできなかった際の症例としての記事に繋がります。

これは「WordPress」などを始める際にある症例で、はてなに置いては全く関係ないようです。私はそれで3日を費やしました。

実際にその方法を試してみると「このサイトにはアクセスできませんでした」と出てきますので、まとめ記事に紹介されていないようなエラーページに飛んだ場合、設定をリセットした方が良いと思います。

 

 

 

 

躓いた点2「独自ドメイン設定が合っているか即時に確認できない」

実際に設定してみて、反映までには「最短15分~最大72時間」位かかるようなのですが「設定が間違っている!」と断定するには72時間待たないといけないのに「設定後の画面を紹介している記事が無い」のです。

私の場合ですが、合っていればこのように表示されているはずです。

f:id:aqn1313:20180206141544p:plain

登録時に「DNSレコード設定用ネームサーバー変更確認」のチェックを入れることで合計5つ登録されるというわけですね。

これが合っているのであれば恐らく設定は何も問題ありません。

 

 

 

 

 

躓いた点3「エラー レコードが見つかりませんでした」と出る

設定が合っていたとしても躓いた点1でも説明した通り「このドメインは、お名前.comで取得されています。」が表示される場合があります。ただ、いくら待ってもその画面に繋がったり、設定直後は不安定になりがちのようです。

f:id:aqn1313:20180206142505p:plain

このように実際に接続が確認された後でも「エラー レコードが見つかりませんでした」と表示される場合があります。何度もチェックすれば有効になりますがエラーなんて出たらやはり「何か間違っていたのかな・・・」と不安になりますよね。

 

 

設定が合っていたのに私が確認した症例は以下の通りです

  1. 取得したドメインにアクセスすると「このドメインは、お名前.comで取得されています。」と表示される
  2. 1度接続を確認したはずが少し時間を置くと「このドメインは、お名前.comで取得されています。」と再度表示される
  3. 取得したドメインにアクセスしたのにURLに「hatenablog」が付いたURLに接続してしまう
  4. ドメインの設定状況」が「有効」になったり「エラー」になったりする

これらの症例はブラウザのキャッシュクリアを試してみたり、別ブラウザで取得したドメインにアクセスしてみたりしても挙動は変われど改善しませんでした。

 

 

そこで私が取った対応策は非常にシンプルです。

  • PCの再起動

  • モデムの再起動(10分以上あける)

この2つだけです。

モデムについては電源を抜いた後すぐ起動せずに、10分は時間を置いて起動してみてください。これで私の場合は解決しました。

ただ反映には時間がかかることもありすぐに解決するかは微妙ですが、私の場合は設定から4~5時間経過した現在、徐々に安定してきています。

上記の症状で困っている人は2つを再起動してみましょう。

 

それではまた。